package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/[a-zA-Z0-9\-_\.]+)(\/[a-zA-Z0-9\-_\.]+)(\/[a-zA-Z0-9\-_]*)*$`)
var str = `http://not.website.com/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzdWIiOiIxMjM0NTY3ODkwIiwibmFtZSI6IkpvaG4gRG9lIiwiYWRtaW4iOnRydWV9.TJVA95OrM7E2cBab30RMHrHDcEfxjoYZgeFONFh7HgQ/test/test`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}