re = /^(?=.*[0-9])(?=.*[A-Za-z])(?=.*[!\x22\#$%&@'()*+,-.\/_])[\w!\x22\#$%&@'()*+,-.\/]{8,}$/
str = 'ddfffr3...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end