re = /:\s+(?<a>[^ ]+)\s+-\>\s+(?<b>[^ ]+)/m
str = 'Service ABCD(blabla_blabla): 365.45.1.87.3.60354 -> remote.234.5 Failure
Service DERF(blabla_blabla): remote.567.9 -> remote.284.9 Failure'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end