#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):\s+(?<a>[^ ]+)\s+-\>\s+(?<b>[^ ]+)\s+Failure"
Local $sString = "Service ABCD(blabla_blabla): 365.45.1.87.3.60354 -> remote.234.5 Failure" & @CRLF & _
"Service DERF(blabla_blabla): remote.567.9 -> remote.284.9 Failure"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")