re = /<!--.*-->/
str = 'blah <!-- first --> yaddahyaddah <!-- second --> other random words.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end