const regex = /\[(youtube )(\s*)([http:\/\/(?:www\.)?youtube.com\/watch\?(?=.*v=\w+)(?:\S+)?$]+)\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(youtube )(\\s*)([http:\\\/\\\/(?:www\\.)?youtube.com\\\/watch\\?(?=.*v=\\w+)(?:\\S+)?$]+)\\]', '')
const str = `[youtube http://www.youtube.com/watch?v=XpsDr1qePxA]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}