$re = '/_*(\[.*?\]|\(.*?\))_*/';
$str = '[Report]_first_day_of_month_01_(generated_by_powershell)_[repnbr1].txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);