$re = '/\b(?!megayacht\b)\w*gay\w*/m';
$str = 'megayacht
megay
gayacht';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);