$re = '/^[\w.-]+@[\w.-]+\.\w+$/';
$str = 'halatwumasi@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);