import re
regex = re.compile(r"<img.*?src=\"[^\"]+\?contextId[^>]+>")
test_str = "<img xmlns=\"http://www.w3.org/1999/xhtml\" src=\"http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier\" alt=\"Bild Übersicht Router\" title=\"Übersicht Router\" />"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")