re = /(?<!^)\b(?:the|an?|[io]n|at|with|from)\b(*SKIP)(*FAIL)|\b(\pL)/m
str = 'I like the pizza
the water in the pool'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end