$re = '/^General(.*?)^General|[\s]/ms';
$str = 'General
Complete name : G:\\VIDEO_TS\\VTS_04_1.VOB
Format : MPEG-PS
File size : 1 024 MiB
Duration : 29 min 25 s
Overall bit rate mode : Variable
Overall bit rate : 4 867 kb/s
Video
ID : 224 (0xE0)
Format : MPEG Video
Format version : Version 2
Format profile : Main@Main
Format settings : CustomMatrix / BVOP
Format settings, BVOP : Yes
Format settings, Matrix : Custom
Format settings, GOP : M=3, N=15
Format settings, picture structure : Frame
Duration : 29 min 25 s
Bit rate mode : Variable
Bit rate : 3 650 kb/s
Maximum bit rate : 8 500 kb/s
Width : 720 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Frame rate : 29.970 (30000/1001) FPS
Standard : NTSC
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.352
Time code of first frame : 00:59:59:15
Time code source : Group of pictures header
GOP, Open/Closed : Closed
Stream size : 768 MiB (75%)
Audio #1
ID : 189 (0xBD)-128 (0x80)
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Muxing mode : DVD-Video
Duration : 29 min 24 s
Bit rate mode : Constant
Bit rate : 448 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 94.2 MiB (9%)
Service kind : Complete Main
Audio #2
ID : 189 (0xBD)-129 (0x81)
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Muxing mode : DVD-Video
Duration : 29 min 24 s
Bit rate mode : Constant
Bit rate : 448 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 94.2 MiB (9%)
Service kind : Complete Main
Audio #3
ID : 189 (0xBD)-130 (0x82)
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Muxing mode : DVD-Video
Duration : 29 min 24 s
Bit rate mode : Constant
Bit rate : 224 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 47.1 MiB (5%)
Service kind : Complete Main
Text
ID : 189 (0xBD)-33 (0x21)
Format : RLE
Format/Info : Run-length encoding
Muxing mode : DVD-Video
Delay relative to video : 7 s 874 ms
General
Complete name : G:\\VIDEO_TS\\VTS_04_0.IFO
Format : DVD Video
Format profile : Program
File size : 68.0 KiB
Duration : 1 h 37 min
Overall bit rate mode : Variable
Overall bit rate : 95 b/s
Video
ID : 224 (0xE0)
Format : MPEG Video
Format version : Version 2
Duration : 1 h 37 min
Bit rate mode : Variable
Width : 720 pixels
Height : 480 pixels
Display aspect ratio : 16:9
Frame rate : 29.970 (29970/1000) FPS
Standard : NTSC
Compression mode : Lossy
Duration_Source : General_Duration
Audio #1
ID : 128 (0x80)
Format : AC-3
Format/Info : Audio Coding 3
Duration : 1 h 37 min
Channel(s) : 2 channels
Sampling rate : 48.0 kHz
Compression mode : Lossy
Language : Chinese
Duration_Source : General_Duration
Audio #2
ID : 129 (0x81)
Format : AC-3
Format/Info : Audio Coding 3
Duration : 1 h 37 min
Channel(s) : 6 channels
Sampling rate : 48.0 kHz
Compression mode : Lossy
Language : Chinese
Duration_Source : General_Duration
Audio #3
ID : 130 (0x82)
Format : AC-3
Format/Info : Audio Coding 3
Duration : 1 h 37 min
Channel(s) : 2 channels
Sampling rate : 48.0 kHz
Compression mode : Lossy
Language : Portuguese
Duration_Source : General_Duration
Text #1
ID : 32 (0x20)
Format : RLE
Format/Info : Run-length encoding
Bit depth : 2 bits
Language : Portuguese
Text #2
ID : 33 (0x21)
Format : RLE
Format/Info : Run-length encoding
Bit depth : 2 bits
Menu
Duration : 1 h 37 min
00:00:00.000 : Chapter 1
00:07:10.500 : Chapter 2
00:14:26.500 : Chapter 3
00:23:42.000 : Chapter 4
00:31:12.000 : Chapter 5
00:39:38.000 : Chapter 6
00:46:15.500 : Chapter 7
00:55:23.500 : Chapter 8
01:02:27.500 : Chapter 9
01:10:12.500 : Chapter 10
01:19:13.500 : Chapter 11
01:26:13.000 : Chapter 12
01:37:46.200 : Chapter 13
List (Audio) : 0 / 1 / 2
List (Subtitles 4/3) : 0 / 0
List (Subtitles Wide) : 0 / 1
List (Subtitles Letterbox) : 0 / 1
List (Subtitles Pan&Scan) : 0 / 1
General
Unique ID : 265651434810034235117589437423295755026 (0xC7DA9AF5666AD1527A66985978717312)
Complete name : Aladdin.1992.2160p.UHD.BluRay.x265-TERMiNAL.DUAL-Lannister.mkv
Format : Matroska
Format version : Version 4
File size : 8.02 GiB
Duration : 1 h 30 min
Overall bit rate mode : Variable
Overall bit rate : 12.7 Mb/s
Encoded date : UTC 2019-09-12 17:17:31
Writing application : mkvmerge v22.0.0 (\'At The End Of The World\') 64-bit
Writing library : libebml v1.3.5 + libmatroska v1.4.8
Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
HDR format : SMPTE ST 2086, HDR10 compatible
Codec ID : V_MPEGH/ISO/HEVC
Duration : 1 h 30 min
Bit rate : 6 532 kb/s
Width : 3 584 pixels
Height : 2 160 pixels
Display aspect ratio : 5:3
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.035
Stream size : 4.14 GiB (52%)
Writing library : x265 3.1+11-de920e0a3183:[Windows][GCC 6.3.0][64 bit] 10bit
Encoding settings : cpuid=1176575 / frame-threads=6 / numa-pools=36 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=1 / input-res=3584x2160 / interlace=0 / total-frames=130417 / level-idc=51 / high-tier=1 / uhd-bd=0 / ref=4 / no-allow-non-conformance / repeat-headers / annexb / aud / hrd / info / hash=0 / no-temporal-layers / no-open-gop / min-keyint=1 / keyint=24 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=25 / lookahead-slices=4 / scenecut=40 / radl=0 / no-splice / no-intra-refresh / ctu=64 / min-cu-size=8 / rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=2 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / no-strong-intra-smoothing / max-merge=3 / limit-refs=3 / limit-modes / me=3 / subme=3 / merange=57 / temporal-mvp / no-hme / weightp / no-weightb / no-analyze-src-pics / deblock=-3:-3 / no-sao / no-sao-non-deblock / rd=4 / no-early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / no-b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=2.00 / psy-rdoq=1.00 / no-rd-refine / no-lossless / cbqpoffs=0 / crqpoffs=0 / rc=crf / crf=17.0 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / vbv-maxrate=160000 / vbv-bufsize=160000 / vbv-init=0.9 / crf-max=0.0 / crf-min=0.0 / ipratio=1.40 / pbratio=1.30 / aq-mode=2 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=1 / overscan=0 / videoformat=5 / range=0 / colorprim=9 / transfer=16 / colormatrix=9 / chromaloc=1 / chromaloc-top=2 / chromaloc-bottom=2 / display-window=0 / master-display=G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,20)cll=0,0 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / hdr / hdr-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=5 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=0 / refine-ctu-distortion=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-analysis-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei / no-hevc-aq / no-svt / no-field / qp-adaptation-range=1.00
Default : Yes
Forced : No
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0020 cd/m2, max: 1000 cd/m2
Audio #1
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : A_AC3
Duration : 1 h 30 min
Bit rate mode : Constant
Bit rate : 640 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 415 MiB (5%)
Title : by Lannister
Language: Portuguese
Service kind : Complete Main
Default : Yes
Forced : Yes
Audio #2
ID : 3
Format : MLP FBA 16-ch
Format/Info : Meridian Lossless Packing FBA with 16-channel presentation
Commercial name : Dolby TrueHD with Dolby Atmos
Codec ID : A_TRUEHD
Duration : 1 h 30 min
Bit rate mode : Variable
Bit rate : 4 768 kb/s
Maximum bit rate : 6 816 kb/s
Channel(s) : 8 channels
Channel layout : L R C LFE Ls Rs Lb Rb
Sampling rate : 48.0 kHz
Frame rate : 1 200.000 FPS (40 SPF)
Compression mode : Lossless
Stream size : 3.02 GiB (38%)
Language : English
Default : No
Forced : No
Number of dynamic objects : 13
Bed channel count : 1 channel
Bed channel configuration : LFE
Audio #3
ID : 4
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : A_AC3
Duration : 1 h 30 min
Bit rate mode : Constant
Bit rate : 640 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 415 MiB (5%)
Language : English
Service kind : Complete Main
Default : No
Forced : No
Text
ID : 5
Format : PGS
Muxing mode : zlib
Codec ID : S_HDMV/PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Duration : 1 h 29 min
Bit rate : 35.9 kb/s
Count of elements : 2352
Stream size : 23.0 MiB (0%)
Language : Portuguese
Default : No
Forced : No
General
Unique ID : 96295411837011032641642823181481344850 (0x4871D25C0188DBA1F9468FCC41F8FF52)
Complete name : Coração Valente 1995 4k 2160p Dual Audio.mkv
Format : Matroska
Format version : Version 4
File size : 45.7 GiB
Duration : 2 h 57 min
Overall bit rate : 36.9 Mb/s
Movie name : Coração Valente
Encoded date : UTC 2019-09-24 12:13:44
Writing application : mkvmerge v37.0.0 (\'Leave It\') 64-bit
Writing library : libebml v1.3.9 + libmatroska v1.5.2
Cover : Yes
Attachments : cover3.jpeg
Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
HDR format : SMPTE ST 2086, HDR10 compatible
Codec ID : V_MPEGH/ISO/HEVC
Duration : 2 h 57 min
Bit rate : 36.0 Mb/s
Width : 3 840 pixels
Height : 1 634 pixels
Display aspect ratio : 2.35:1
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.239
Stream size : 44.7 GiB (98%)
Title : DUAL AUDIO
Writing library : x265 2.7+348-0968a46d6ba4:[Windows][GCC 7.3.0][64 bit] 10bit
Encoding settings : cpuid=1176575 / frame-threads=5 / numa-pools=32 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=1 / input-res=3840x1634 / interlace=0 / total-frames=255642 / level-idc=51 / high-tier=1 / uhd-bd=0 / ref=4 / no-allow-non-conformance / repeat-headers / annexb / aud / hrd / info / hash=0 / no-temporal-layers / no-open-gop / min-keyint=24 / keyint=240 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=25 / lookahead-slices=4 / scenecut=40 / radl=0 / no-intra-refresh / ctu=64 / min-cu-size=8 / rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=2 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / no-strong-intra-smoothing / max-merge=3 / limit-refs=3 / limit-modes / me=3 / subme=3 / merange=57 / temporal-mvp / weightp / no-weightb / no-analyze-src-pics / deblock=-3:-3 / no-sao / no-sao-non-deblock / rd=4 / no-early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / no-b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=2.00 / psy-rdoq=1.00 / no-rd-refine / no-lossless / cbqpoffs=0 / crqpoffs=0 / rc=crf / crf=18.0 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / vbv-maxrate=160000 / vbv-bufsize=160000 / vbv-init=0.9 / crf-max=0.0 / crf-min=0.0 / ipratio=1.40 / pbratio=1.30 / aq-mode=1 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=1 / overscan=0 / videoformat=5 / range=0 / colorprim=9 / transfer=16 / colormatrix=9 / chromaloc=1 / chromaloc-top=2 / chromaloc-bottom=2 / display-window=0 / master-display=G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(10000000,1) / max-cll=0,0 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / hdr / hdr-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=5 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-mv-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei
Language : Portuguese
Default : Yes
Forced : Yes
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0001 cd/m2, max: 1000 cd/m2
Audio #1
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : A_AC3
Duration : 2 h 57 min
Bit rate mode : Constant
Bit rate : 192 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 244 MiB (1%)
Title : AC3 2.0
Language : Portuguese
Service kind : Complete Main
Default : Yes
Forced : Yes
Audio #2ID : 3
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : A_AC3
Duration : 2 h 57 min
Bit rate mode : Constant
Bit rate : 640 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 2 s 169 ms
Stream size : 813 MiB (2%)
Title : AC-3 5.1
Language : English
Service kind : Complete Main
Default : No
Forced : No
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);