#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\s|^)((\w+)(?:\s+\2)+)(?:\s|$)"
Local $sString = "Paris in the the spring." & @CRLF & _
"Not that that is related." & @CRLF & _
"Not that that that is related." & @CRLF & _
"" & @CRLF & _
"This is $word word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")