$re = '/^([0-9][0-9]*)+(\.[0-9]{1,2})?$/m';
$str = '1564654
dfh
EDGEGE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);