$re = '/([^\D0])/';
$str = 'a=023-98752093847102948752304571234612495827345asdfashdf092139740219yo34itu320487oih';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);