re = /(^.*)(?=table)|(?!.*table.*)(^.+)/m
str = 'diningtable
cookingtable
cooking
table'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end