re = /{{\s*(.*?)\s*}}/
str = ' {{SOME_STRING}}
{{ SOME_STRING}}
{{ SOME_STRING }}
{{ SOME-STRING }}
{{ SomE STRING }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end