use strict;
my $str = '123456_B--7545
';
my $regex = qr/_(B|T)\-{2,4}\d{4}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";