import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:31(\\/|-| |\\.)(?:0?[13578]|1[02]|(?:Jan|January|Mar|March|May|Jul|July|Aug|August|Oct|October|Dec|December)))\\1|(?:(?:29|30)(\\/|-| |\\.)(?:0?[1,3-9]|1[0-2]|(?:Jan|January|Mar|March|Apr|April|May|Jun|June|Jul|July|Aug|August|Sep|September|Oct|October|Nov|November|Dec|December))\\2))(?:(?:1[6-9]|[2-9]\\d)?\\d{2})\\b|\\b(?:29(\\/|-| |\\.)(?:0?2|(?:Feb|February))\\3(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))\\b|\\b(?:0?[1-9]|1\\d|2[0-8])(\\/|-| |\\.)(?:(?:0?[1-9]|(?:Jan|January|Feb|February|Mar|March|Apr|April|May|Jun|June|Jul|July|Aug|August|Sep|September))|(?:1[0-2]|(?:Oct|October|Nov|November|Dec|December)))\\4(?:(?:1[6-9]|[2-9]\\d)?\\d{2})\\b";
final String string = "From 1 March 1960 To 1 March 2235\n\n"
+ "For a period starting 01/03/1960 and ending 01/03/2235\n\n"
+ "Starting 1.3.1960 and ending 1.3.2235\n\n"
+ "For a period starting 1/3/1960 and ending 1/3/2235\n"
+ "From 1 June 1960 To 1 July 2235\n"
+ "From 1-June-1960 To 1-July-2235\n\n"
+ "29-02-2008\n"
+ "29-Feb-2008\n"
+ "29-02-2009\n"
+ "29-Feb-2009\n"
+ "29/Feb/20\n"
+ "29-Feb-21\n\n"
+ "29-10-2008\n"
+ "31-12-2008\n"
+ "31-11-2008\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}