$re = '/([^\[a-z_0-9\-]|^)([a-z_\-][a-z0-9_\-]*:)/i';
$str = 'Return-Path: Received: from out.ipsmtp4nec.opaltelecom.net (out.ipsmtp4nec.opaltelecom.net [62.24.202.76]) by smartermail.divtech.co.za with SMTP; Mon, 6 Jul 2015 12:59:14 +0200 X-SMTPAUTH: sailor26@tiscali.co.uk X-IronPort-Anti-Spam-Filtered: true X-IronPort-Anti-Spam-Result: A2DSrwBOXppVPOPoVl0aAUErgmdUYIMfp3gMBgGBA4IZK4VrAYJ3V4ckhW8EKYEFTQEBAQEBAQcBAQEBQAE/HwEBIAECAoNdAQIMGzMuCgYDAQIPHw4COwoCCAEGCQESCAmICAMWCZFaoGKWHYYdhS6CTR6FCi+BFAWFXAqOLQIBhGGFJ4FfkTmHHYFvAQEIAQEBAQEBgiI+MYJLAQEB X-IPAS-Result: A2DSrwBOXppVPOPoVl0aAUErgmdUYIMfp3gMBgGBA4IZK4VrAYJ3V4ckhW8EKYEFTQEBAQEBAQcBAQEBQAE/HwEBIAECAoNdAQIMGzMuCgYDAQIPHw4COwoCCAEGCQESCAmICAMWCZFaoGKWHYYdhS6CTR6FCi+BFAWFXAqOLQIBhGGFJ4FfkTmHHYFvAQEIAQEBAQEBgiI+MYJLAQEB X-Header: TalkTalk X-IronPort-AV: E=Sophos;i=""5.15,414,1432594800""; d=""scan\'208,217"";a=""693647776"" Received: from 93-86-232-227.dynamic.isp.telekom.rs (HELO smtp.tiscali.co.uk) ([93.86.232.227]) by out.ipsmtp4nec.opaltelecom.net with ESMTP; 06 Jul 2015 11:59:04 +0100 Message-ID: From: "jonjon.bracq" To: "Webtickets" , "Webtickets Highlights" , "RYA" , "www jobonyachts com ADMIN" , "RYA InBrief" , "RYA InBrief" , "Webtickets Highlights" , "Webtickets Regional Highlights" , "RYA InBrief" Subject:
=?ISO-8859-1?Q?FW=3AFrom=3Ajonjon.bracq=40yahoo.com?= Date: Thu, 26 Jun 2015 11:59:43 +0000 MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="----=_NextPart_000_00BE_8320AA74.4FC1860E" X-Priority: 3 X-MSMail-Priority: Normal Importance: Normal X-Mailer: Microsoft Windows Live Mail 16.4.3522.110 X-MIMEOLE: Produced By Microsoft MimeOLE V16.4.3522.110 X-SmarterMail-Spam: SPF_Pass, RHSBL, UCEProtect Level 1, Bayesian Filtering, ISpamAssassin 0 [raw: 0], DK_None, DKIM_None, Custom Rules [] X-SmarterMail-TotalSpamWeight: 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);