re = /(?<![a-z])(?:[aeiou](?:[^P{L}aeiou][aeiou])+|[^\P{L}aeiou](?:[aeiou][^\P{L}aeiou])+)(?![a-z])/i
str = 'A quantity of striped words.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end