package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\s+)`)
var str = `
test
aeee
eeeee`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}