$re = '/^ABC (M?T?W?R?F?|N)(?<=\S) ABC$/m';
$str = 'ABC M ABC
ABC MWR ABC
ABC TRF ABC
ABC N ABC
ABC Z ABC
ABC TRM ABC
ABC ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);