const regex = /^(\S+).*Samsung_Galaxy_Note_2/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+).*Samsung_Galaxy_Note_2', 'm')
const str = `List of devices attached
192.168.56.101:5555 device product:vbox86p model:Samsung_Galaxy_Note_2___4_3___API_18___720x1280 device:vbox86p
192.168.56.102:5555 device product:vbox86tp model:Google_Nexus_7___4_3___API_18___800x1280 device:vbox86tp`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);