re = /.*\K&\[.+\]/
str = '[Product].[Product Catalog].[Product].&[50]&[53]&[DE]&[1ST_HQ]&[50_54_36]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end