import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(?<name>\\w+)\\W([\\w\\W]+)!(?<type>G|N)!";
final String string = "@Kate^jfdvbkrjgb!G!\n"
+ "@Bobbie*kjdrrbgk!G!\n"
+ "@Stan#dkjghskd!N!\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}