$re = '/\bby\s(?!.*\bby\b).*?$/i';
$str = 'Go by the office and pickup milk by the safeway BY tomorrow';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);