$re = '/^[\P{L}\D]*?([\p{L}\d])/m';
$str = 'ÉÈDFSF (artist 4)
4 o n
$$#% 4 o n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);