$re = '/^[0-9a-f]{1,2}([.:-])[0-9a-f]{1,2}(?:\1[0-9a-f]{1,2}){4}$/mi';
$str = 'AA-BB.CC.DD.EE.FF
AA.BB.CC.DD.EE.FF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);