using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?># *(*SKIP)(*FAIL)|(?:^|\s))test\.this\.regex\s+\""[^""]*\""";
string input = @" test.this.regex ""sup1"" hi |sup1| # test.this.regex ""sup3"" hi |sup3|
# test.this.regex ""sup2"" do |sup2|
test.this.regex ""sup2"" do |sup2|
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}