import re
regex = re.compile(r"^(?:https?:\/\/)?(?:(?:[\pL0-9-]+)\.)+[\pL]{2,}(?:\/.*)?$", flags=re.IGNORECASE | re.MULTILINE | re.UNICODE)
test_str = ("http://google.com\n"
"https://google.com\n"
"http://google.com/\n"
"https://google.com/\n"
"http://g oogle.com\n"
"http://google.com/somepath\n"
"https://g oogle.com/somepath\n"
"https://g_oogle.com/somepath\n"
"google.com\n"
"google.com/somepath\n"
"goo gle.com/badpath\n"
"кириллица.укр\n"
"кирилл ица.укр\n"
"кириллица.укр/путь\n"
"кирилл01ица.укр\n"
"кирилли-ца.укр/путь\n"
"собдомен.кириллица.укр\n"
"собдомен.кириллица.укр/путь\n"
"2саб.1саб.домен.укр\n"
"2саб.1с-аб.до мен.укр")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")