$re = '/^(?!.*(.).*\1.*\1.*\1).*/m';
$str = '4444121212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);