# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\s+\b/\n/gm;t' <<< "IF THIS IS THE CODE
AND THIS IS THE NEXT LINE
AND THIS IS THE THIRD LINE"