$re = '/^(.(?<!forbidden (word1|word2|word3)\b))*((?<!forbidden )\b(word1|word2|word3)\b)+(.(?<!forbidden (word1|word2|word3)\b))*$/m';
$str = 'hi forbidden hello word1 test forbidden word1
as
hello forbidden word1
forbidden hello word1
word1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);