$re = '/^(?:\+7|8)?9(?:\d{9})$/';
$str = '89200760939';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);