#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<email>(?P<local>(?![\.\ ]+)(?=[^@]+)(?:(?:(?:[\#\!\$\%\&\'\*\+\-\/\=\?\^\_\`\{\|\}\~\p{L}\p{N}])*(?:(?<=\.|^)(?:\"(?:[^\"]|(?<=\\)[\"\(\)\,\:\;\<\>\@\[\\\]])*\")\.?)*(?:[\#\!\$\%\&\'\*\+\-\/\=\?\^\_\`\{\|\}\~\p{L}\p{N}])*)))(?<!\.)\@(?P<host>(?:[\w\-]+?\.?)*|\[[\w\d\:]*\])(?![\.\ ]+))$"
Local $sString = "EMAIL" & @CRLF & _
"________" & @CRLF & _
"john.smith(comment)@example.com" & @CRLF & _
"(comment)john.smith@example.com" & @CRLF & _
"john.smith@(comment)example.com" & @CRLF & _
"john.smith@example.com(comment)" & @CRLF & _
"abc."defghi".xyz@example.com" & @CRLF & _
""abcdefghixyz"@example.com" & @CRLF & _
""John..Doe"@example.com" & @CRLF & _
""test"."test"@test.com" & @CRLF & _
"test."test"@test.com" & @CRLF & _
""test".test@test.com" & @CRLF & _
""\""@test.com" & @CRLF & _
""\"\"".test@test.com" & @CRLF & _
"prettyandsimple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-dash@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
""much.more unusual"@example.com" & @CRLF & _
""very.unusual.@.unusual.com"@example.com" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"#!$%&'*+-/=?^_`{}|~@example.org" & @CRLF & _
""()<>[]:,;@\\\"!#$%&'-/=?^_`{}| ~.a"@example.org" & @CRLF & _
"" "@example.org" & @CRLF & _
"example@localhost" & @CRLF & _
"example@s.solutions" & @CRLF & _
"user@localserver" & @CRLF & _
"user@tt" & @CRLF & _
"user@[IPv6:2001:DB8::1]" & @CRLF & _
"________" & @CRLF & _
"@test.com" & @CRLF & _
"abc\"def\"ghi@example.com" & @CRLF & _
"abc"defghi"xyz@example.com" & @CRLF & _
"John..Doe@example.com" & @CRLF & _
"Abc.example.com" & @CRLF & _
"A@b@c@example.com" & @CRLF & _
""\""".""@test.com" & @CRLF & _
"test"@test.com" & @CRLF & _
"."".@test.com" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com" & @CRLF & _
"just"not"right@example.com" & @CRLF & _
"this is"not\allowed@example.com" & @CRLF & _
"this\ still\"not\\allowed@example.com" & @CRLF & _
"john..doe@example.com" & @CRLF & _
"john.doe@example..com.somethingelse.something.more..more" & @CRLF & _
" john.doe@example.com" & @CRLF & _
"john.doe@example.com " & @CRLF & _
".john.doe@something.com" & @CRLF & _
"johndoe.@something.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")