re = /^(?!000|666)[0-8][0-9]{2}-(?!00)[0-9]{2}-(?!0000)[0-9]{4}$/m
str = '333-33-3333
not a social
33333333
333-33l3333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end