$re = '/^(?:[^_\n]+_)+(?!\d+$)[^_\n]+/m';
$str = 'lorem_ipsum_test1_123
lorem_ipsum_test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);