$re = '/((http|https|ftp)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(:[a-zA-Z0-9]*)?\/?([a-zA-Z0-9\-\._\?\,\'\/\\\\\+&%\$#\=~])*)/';
$str = 'sdfas https://seyler.eksisozluk.com/yaptigi-her-aramanin-sonuna-tesekkurler-ekleyen-sirin-buyukanneye-googledan-jest asdfasdf asd asdf asdf asd fasdf asdf asd f ads fa dsf ads f asdf asd f asd fa dsf ad fa dsf asd fa ds fas df asd fa sdf asd fa sf asd fa s fas dfa dsf ad fa df ad fa sdf asd f asd f d fads f ads fas df ads f asdf sad fds f df d f dfhgasdjhkfgjahdsgfasjdkhgkjhdsgajhbc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);