$re = '/\[([^]]+)\]\s+\[([^]]+)\]\s+(?:\(([^)]+)\))?(\D+)\s+([\d:.]+)\s+\(([^)]+)\)\D+([\d.]+)/x';
$str = '[Mon May 19 15:56:43 2014] [error] proxy: pass request body failed to 111.111.111.111:3000 (111.111.111.111) from 111.111.111.111 ()
[Mon May 19 15:58:00 2014] [error] (70007)The timeout specified has expired: proxy: prefetch request body failed to 111.111.111.111:3000 (111.111.111.111) from 111.111.111.111 ()
[Mon May 19 23:14:56 2014] [error] (70014)End of file found: proxy: prefetch request body failed to 111.111.111.111:3000 (111.111.111.111) from 111.111.111.111 ()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);