re = /^(?<username>\w+)\.(?<group>\w+)(\@masaged\.com)*/imx
str = 'emad.durab@masaged.com
ahemd.ests
عماد.ابوغالي
emad@abc.com
Salem.dearME@masaged.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end