$re = '/(?:ID Number: ([A-Z0-9]{2})|(?<!^)\G):?([A-Z0-9]{2})/m';
$str = 'ID Number: 4D:9B:C4:C6:F1:G5:Y6 foo :C5:D4:Y6';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;