$re = '/((?:(?:\w+)\s+){2})(?=\w+)/';
$str = 'Remi Whatname Say again';
$subst = "\1* ";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;