import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\S+\\s+|\\G(?!^)\\d+\\K|\\G(?!^).*$";
final String string = "\n"
+ "article 11367 airline experts incheon airport transfers operational expertise indonesia\n"
+ "article 8364 future investment korean government invest 4 trillion won science technology ict rd\n"
+ "article 2151 fighter procurement lockheed martin able propose lower prices f 35s\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}