$re = '/^(?!(.*?-){4})(?=.*-).*$/m';
$str = 'asdsa-asdasd
sadasd- -asdasd
asdasd-- -asdsad
asdasd--- -asdsad
asdsadasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);