import Foundation
let pattern = ##"""
(?P<everything>
# Match full URL for debugging
(?P<fullURL>
# Begin hostname isolation
(?P<hostname>
# https://
(?P<protocol>(?:https?:)?\/\/)
# reddit.com or redd.it
(?P<subdomain>(?!about\.)[\w-]+?\.)?(?P<domain>[rc]edd(?:it\.com|\.it))
)
# End hostname isolation
# Do not match any reserved URLs, like reddit.com/gold or reddit.com/advertising
(?!\/(?:blog|about|code|advertising|jobs|rules|wiki|contact|buttons|gold|page|help|prefs|user|message|widget)\b)
# URL path
(?P<subreddit>
# </r/subreddit>
(?:\/r\/[\w-]+\b(?<!\/pcmasterrace))
|
# </tb>
(?:\/tb)
)?
# </comments>/POSTID
(?P<comments>\/comments)??
# Start the Post ID detection, and testing for whether or not it should match a shortlink
(?P<postID>\/\w{2,7}\b(?<!\/46ijrl)(?<!\/wiki))
# Match rest of URL for debugging
(?P<everythingElse>(?:(?!\))\S)*))
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = ##"""
DO NOT MATCH
](/fds
[fdasf](/sw
fjsdalr/CHAN5/comments/2qjq7j/test_post/
https://about.reddit.com/careers/
https://www.reddit.com/46ijrl
https://www.reddit.com/r/chan5/wiki/config/automoderator
MATCH
http://reddit.com/r/CHAN5/comments/2qjq7j/test_post/
np.reddit.com/r/CHAN5/comments/2qjq7j/test_post/
reddit.com/r/CHAN5/comments/2qjq7j/test_post/
/r/CHAN5/comments/2qjq7j/test_post/
r/CHAN5/comments/2qjq7j/test_post/
DO NOT MATCH
/2qjq7j
MATCH
[Full link](http://reddit.com/r/CHAN5/comments/2qjq7j/test_post/)
[Full link](https://reddit.com/r/CHAN5/comments/2qjq7j/test_post/)
[Full with subdomain](//np.reddit.com/r/CHAN5/comments/2qjq7j/test_post/)
[Full with two-part subdomain](//np-dk.reddit.com/r/CHAN5/comments/2qjq7j/test_post/)
[Full without www](//reddit.com/r/CHAN5/comments/2qjq7j/test_post/)
[Without reddit.com](/r/CHAN5/comments/2qjq7j/test_post/)
[Without subreddit](/comments/2qjq7j)
[Ultrashortlink](/2qjq7j)
[Subreddit and post ID (no /comments)](/r/CHAN5/2qjq7j)
[Redd.it](//redd.it/2qjq7j)
[Reddit.com/tb](//reddit.com/tb/2qjq7j)
[Redd.it full link](//redd.it/r/CHAN5/comments/2qjq7j)
[subreddit without comments](/r/chan5/2qjq7j)
[weird other syntax](https://www.reddit.com/comments/3ovgmw/_/cw1h7jn)
[weird other syntax](//www.reddit.com/comments/3ovgmw/)
[weird other syntax](https://www.reddit.com/comments/3ovgmw/ "test")
[weird other syntax](https://www.reddit.com/comments/3ovgmw?context=3)
[Ultrashortlink w/ alt text](/2qjq7j "fdsfa")
[Deprecated toolbar link that still works for some reason](https://www.reddit.com/tb/1y70ej)
https://www.reddit.com/r/SubredditSimulatorMeta/comments/4ksecc/the_anteaters_tongue_is_fully_extended_it_can_be/
DO NOT MATCH
[PCMR](https://reddit.com/r/pcmasterrace)
https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/
https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/d1owcop
https://www.reddit.com/r/pcmasterrace/comments/4d9a43/campaign_to_bring_rock_band_4_to_pc_enters_its/d1oz6if?context=10000
https://i.redd.it/vp2hsd4za4zw.jpg
[Image link](//i.redd.it/vp2hsd4za4zw.jpg)
https://www.reddit.com/gold/about/
https://www.reddit.com/r/SubredditSimulator/comments/4ksecc/the_anteaters_tongue_is_fully_extended_it_can_be/
MATCH (not the first or the non-Reddit link)
If you're looking for more information about this campaign, here are some useful resources.
- [The Harmonix AMA in /r/PCMasterRace](https://www.reddit.com/r/pcmasterrace/comments/4cqxz9/we_are_harmonix_and_only_you_can_help_us_bring/) Tons of questions and answers here.
- [A recent interview with HMXJosh that covers many of the questions asked in the AMA in different levels of detail](https://www.reddit.com/r/Rockband/comments/4co7ta/my_interview_with_josh_from_harmonix_about_rock/)
- [The original announcement thread in /r/RockBand](https://www.reddit.com/r/Rockband/comments/48heg7/rock_band_4_on_pc_gasp_crowdfunding_campaign_is/)
- [A really informative Update on the Fig page specifically abou tthe quality of the PC port](https://www.fig.co/campaigns/rock-band-4-pc?update=97#updates)
- [A collection of HMXJosh posts from the last few days](https://www.reddit.com/r/Rockband/comments/4cr3u3/wondering_about_exports_or_other_hot_topics_heres/)
The biggest draw, in my opinion, is the return of the Rock Band Network. Basically this means user-generated content for sale, and (most likely) free customs as well. RBN on the Xbox 360 brought all kinds of lesser known artists and genres to the game and before long there were many people (myself included) who almost exclusively purchased DLC from there instead of the official store. RBN offered double bass charts for drummers, which is something we've never seen in official DLC either. So the prospect of getting this back is, for me, pretty huge.
On top of this, PC as a platform offers better peripheral support, more powerful graphics options, and an opportunity for a really efficient UI in places where controllers are sub-optimal (eg, searching your song list).
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)