import re
regex = re.compile(r"(?:(\d+)ft)?\s*(?:(\d+)in)?", flags=re.MULTILINE)
test_str = ("5ft 6in\n"
"4ft 1in\n"
"6in\n"
"3ft")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")