re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])[^+&\n]{8,}$/m
str = 'abcdA1
abcda+23
abcdA&c1
abcdefG123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end