re = /\.(doc|docx|log|odt|pages|rtf|txt|csv|key|pps|ppt|pptx|tar|xml|json|pdf|xls|xlsx|db|sql|rar|gz|zip)/i
str = '
.db'
# Print the match result
str.match(re) do |match|
puts match.to_s
end