package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(Ex)(ample)`)
var str = `Examples`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}